Page 1 of 1

Epson RX500 -- new ink carts.--says it's empty.

PostPosted: Sun Jan 20, 2008 1:49 pm
by guvna
Hello my Epson RX500 has been running great for a couple of years.
It ran out of black ink but after replacing it I got an error message saying that ALL my colors were out, including the new black one. The screen that shows how much is left for each color doesn't show any of the colors or their levels -- the area is just blank.

A couple of months ago I had a similar issue where I got a message saying my yellow was out, but I knew it wasn't. I took the yellow cartridge out, shook it to confirm there was lots of ink there, then put it back in. It worked. I tried that this time when it said all the inks were out but it didn't work.

I contacted Epson by email and got referred to a repair facility without saying anything about what might be wrong so they were no help.

I really like the scanner portion of this unit (scans to 2400 instead of 1200 with the newer ones) so I'd like to keep using the printer too.

If this is a common problem can y'all bring me up to speed on the issue?
BTW I'm using it on a Mac OS 10.4.11.